• Re: Tech: WPC89 Loses Memory

    From LexingtonVAPin@lhammer610@yahoo.com to rec.games.pinball on Sunday, April 05, 2020 12:29:53
    From Newsgroup: rec.games.pinball

    On 3/25/20 4:01 PM, John Robertson wrote:
    On 2020/03/25 10:42 a.m., LexingtonVAPin wrote:
    On 3/13/20 2:06 PM, John Robertson wrote:
    On 2020/03/13 8:51 a.m., LexingtonVAPin wrote:
    I picked up a HS2 - Getaway.  Was told it loses memory.

    I removed the AA holder and installed a watch battery holder.  I did >>>> not notice any battery leakage damage.

    I also re-seated the EPROM.  We saw a program error at one point a
    couple of months ago. Everything was fine for about two weeks.

    I started up the game yesterday and got a factory reset note, so the
    watch battery did not solve the problem.   But when I reset it to
    free play, I noticed that the date/time was accurate and not lost.
    All the other settings (free play, high scores, other presetting,
    etc.) appear to be lost.

    Any suggestions?

    If the clock settings are retained (that means the ASIC chip has
    battery power) then I would be checking if the CMOS RAM had voltage
    on pin 24 (28) that is at least 3VDC when the game is turned off. I
    suspect the problem is either the CMOS RAM is defective (not too
    likely as the game wouldn't boot normally) or a batter power issue
    that is only to the CMOS RAM.

    John :-#)#

    After thinking I solved this problem, two weeks later, the pin starts
    up with a factory setting notice again.

    It did this two starts in a row.  At one point, it did not even retain
    settings after backing out of the service menu.  Then it worked.

    Now, today, I start up and get a checksum error.  Last time that
    happened, re-seating the EPROM made the problem go away.

    As before, date and time are saved, meaning the ASIC is OK.

    Is my checksum error related to the RAM?  Or am I potentially having
    an issue with the EPROM socket or the EPROM itself?

    My recollection is that when I upgrade EPROMs in WPC pins, the factory
    settings are restored, even if power is left to the RAM.  That tells
    me that the issue might be with the EPROM / socket?

    What is the voltage at the CMOS RAM pin 28 with the game turned off for
    a while? If below around 2.25VDC then the CMOS RAM may not retain
    settings and you will get that error...

    And, yes when you upgrade the EPROM the game will give you the Factory Settings error, but if it was not seated the game wouldn't boot!

    Any battery corrosion (or history) on your board? I'd be checking traces carefully...

    John :-#)#

    I hesitate to declare victory, but it has been two weeks since I lost
    memory on this pin.

    Since I had gotten a checksum error, I thought it might be related to
    the EPROM. I resoldered the EPROM socket to the board. And pulled,
    cleaned the legs of the EPROM and re-seated it.

    If it crops up again, I will burn a new EPROM. If that does not fix it, replace the socket.

    --- Synchronet 3.17c-Win32 NewsLink 1.112